Android App Unavailable on Google Play
Incident Report for TrueLearn LLC
Resolved
The TrueLearn App is now available in the Google Play Store. Thank you for your patience while we worked on resolving the issue. If you have any questions or concerns, please feel free to contact TrueLearn Support (support@truelearn.com).
Posted about 2 months ago. May 30, 2019 - 08:46 EDT
Investigating
Our Android app is no longer available through Google Play. We are currently working closely with Google Support to restore the app. Please be aware that you can access the interface through your device's mobile browser. We apologize for the inconvenience.
Posted 3 months ago. Apr 24, 2019 - 15:41 EDT
This incident affected: Mobile App - Android.