Display Issues During Testing
Incident Report for TrueLearn LLC
Resolved
This incident has been resolved.
Posted about 1 year ago. Oct 17, 2018 - 10:02 EDT
Investigating
We are currently investigating reports of display issues affecting our testing interface. We apologize for any inconveniences you may be experiencing at present. Our team is diligently working to correct the issues that have been reported.
Posted about 1 year ago. Oct 17, 2018 - 09:42 EDT
This incident affected: Member Website - www.truelearn.net.