Possible System Disruption (3am-6am EST)
Incident Report for TrueLearn LLC
Resolved
This incident has been resolved.
Posted Nov 13, 2020 - 14:37 EST
Monitoring
Users may experience a disruption in the platform between the hours of 3am to 6am EST. Our team is currently monitoring the situation. We appreciate your patience.

Please reach out to TL Support if you have questions or need assistance: support@truelearn.com.
Posted Nov 12, 2020 - 16:54 EST
This incident affected: Member Website - www.truelearn.net, Faculty Administrator Website - admin.truelearn.net, Content Team Website - admin.truelearn.net, Mobile App - iOS, and Mobile App - Android.